Phone Service Disruption

Incident Report for Swedbank Pay

Resolved

This incident has been resolved.
Posted May 19, 2026 - 17:30 CEST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 19, 2026 - 16:38 CEST

Identified

We are currently experiencing issues with our phone lines due to a disruption at our provider. As a result, it may be difficult to reach us by phone.

In the meantime, please contact us via email:

For questions regarding card acquiring, email: support@swedbankpay.se
For questions regarding payment terminals or e-commerce, email: support.psp@swedbankpay.se
To reach our sales department, email: sales@swedbankpay.se

We are working with our provider to resolve the issue as quickly as possible.

We apologize for the inconvenience and appreciate your patience.
Posted May 19, 2026 - 16:08 CEST
This incident affected: Contact Channels.