Service Disruption - Terminals using mobile/SIM connectivity

Incident Report for Swedbank Pay

Monitoring

The service is now stable and is being monitored.
Posted Dec 03, 2025 - 17:38 CET

Investigating

We are currently experiencing a service disruption with PAX-terminals using SIM-cards. We are working to restore the service as soon as possible. Thank you for your patience.

Service is functioning via Wi-Fi.

How to Connect Your PAX Terminal to Wi-Fi:

1. Tap the three dots in the bottom-left corner of the screen.
2. Select Admin Menu.
3. Enter your Admin Code.
4. Go to Settings.
5. Choose Network Settings.
6. Select Wi-Fi and connect to your preferred network.
Posted Dec 03, 2025 - 16:07 CET
This incident affects: Payment Solutions (Instore Card Payments).