Swish Service Disruption
Incident Report for Swedbank Pay
Resolved
This incident has been resolved.
Posted Sep 06, 2024 - 13:09 CEST
Update
Swish are experiencing an outage and is investigating.
Posted Sep 06, 2024 - 12:51 CEST
Update
We are continuing to investigate this issue.
Posted Sep 06, 2024 - 12:40 CEST
Investigating
We are currently experiencing a service disruption. We are working to restore the service as soon as possible. Thank you for your patience.
Posted Sep 06, 2024 - 12:34 CEST
This incident affected: Payment Solutions (Swish).