Issues in Merchant Portal affecting login

Incident Report for Swedbank Pay

Resolved

This incident has been resolved.
Posted Mar 05, 2025 - 16:02 CET

Identified

If you are experiencing troubles reaching the merchant portal, try clearing stored cookies and cache from your browser.
Posted Mar 05, 2025 - 11:48 CET

Investigating

We are currently experiencing issues with the Merchant Portal which affects the ability to access the portal.

The issue is being worked on to restore full functionality as soon as possible.

Thank you for your patience.
Posted Mar 05, 2025 - 11:19 CET
This incident affected: Web Portal's (Merchant Portal).