Issue with BankID login in Merchant Portal (SE)

Incident Report for Swedbank Pay

Resolved

This incident has been resolved.
Posted May 15, 2025 - 10:58 CEST

Investigating

We are currently experiencing issues with login via Mobile BankID in the Merchant Portal for Swedish users. Our technical team is investigating the root cause and working to resolve the issue.

We will provide an update as soon as more information is available.
Thank you for your patience
Posted May 15, 2025 - 10:34 CEST
This incident affected: Web Portal's (Merchant Portal).