Swedbank Pay - Delayed payouts

Incident Report for Swedbank Pay

Resolved

This incident has been resolved.
Posted May 08, 2025 - 09:32 CEST

Monitoring

Payouts are expected to be made tomorrow, Thursday, May 8th.
Posted May 07, 2025 - 16:40 CEST

Update

We are continuing to work on a fix for this issue.
Posted May 07, 2025 - 09:24 CEST

Identified

We are currently experiencing issues with clearing and settlement which may result in delays in payouts for some customers with Swedbank Pay as their PSP. We apologize for any inconvenience this may cause and are working to resolve this matter promptly.
Posted May 06, 2025 - 09:22 CEST
This incident affected: Acquiring of Card Transactions (Clearing & Settlement).