Invoice Delivery Delay

Incident Report for Swedbank Pay

Resolved

This incident has been resolved.
Posted Nov 13, 2025 - 16:00 CET

Investigating

We are currently experiencing a delay in sending out invoices, which may affect some customers. We are actively working to distribute the invoices as soon as possible and will provide an estimated timeline as soon as we have more information. Thank you for your patience!
Posted Nov 12, 2025 - 11:45 CET
This incident affected: Invoicing.