Authorization disturbances Nov 19th
Incident Report for Swedbank Pay
Resolved
The processing of authorizations is back to normal.
Posted Nov 19, 2024 - 11:57 CET
Investigating
There may be disturbances with the authorization service. We are investigating.
Posted Nov 19, 2024 - 10:59 CET
This incident affected: Acquiring of Card Transactions (Card Authorization).