Swish disturbance

Incident Report for Swedbank Pay

Resolved

This incident has been resolved.
Posted May 25, 2025 - 00:33 CEST

Identified

Swish reportinh disturbance in service
Posted May 22, 2025 - 13:18 CEST
This incident affected: Payment Solutions (Swish).