Due to some technical difficulties you might experience some trouble getting in touch with us.
Incident Report for Swedbank Pay
Resolved
This incident has been resolved.
Posted Jan 24, 2023 - 08:49 CET
Update
We are continuing to monitor for any further issues.
Posted Jan 24, 2023 - 08:49 CET
Update
We are continuing to monitor for any further issues.
Posted Jan 23, 2023 - 18:16 CET
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jan 23, 2023 - 18:14 CET
Update
There still might be some difficulties getting in touch with us. Please be patient.
Posted Jan 23, 2023 - 17:05 CET
Investigating
We are currently investigating this issue.
Posted Jan 23, 2023 - 12:11 CET