Verifone - Disturbances with clearing and settlement

Incident Report for Swedbank Pay

Resolved

This incident has been resolved.
Posted 16 days ago. Mar 20, 2025 - 08:27 CET

Identified

Verifone are currently having issues with clearing files which will cause delays with payouts to some customers.
We apologise for any inconvenience this may cause.
Posted 17 days ago. Mar 19, 2025 - 09:53 CET
This incident affected: Acquiring of Card Transactions (Clearing & Settlement).