ApplePay Service Disruption

Incident Report for Swedbank Pay

Resolved

This incident has been resolved.
Posted Oct 07, 2025 - 12:43 CEST

Update

We are still experiencing a service disruption. We are working to restore the service as soon as possible. Thank you for your patience. This only affects ApplePay payments, not normal card payments.
Posted Oct 07, 2025 - 11:58 CEST

Update

We are currently experiencing a service disruption. We are working to restore the service as soon as possible. Thank you for your patience. This only affects ApplePay payments, not normal card payments.
Posted Oct 07, 2025 - 10:57 CEST

Investigating

We are currently experiencing a service disruption. We are working to restore the service as soon as possible. Thank you for your patience.
Posted Oct 07, 2025 - 10:50 CEST
This incident affected: Payment Solutions (m/ecom Card Payments).