Swish Service Disruption

Incident Report for Swedbank Pay

Resolved

This incident has been resolved.
Posted Feb 27, 2026 - 10:14 CET

Identified

At the moment, Nordea is experiencing a disturbance that may impact Swish transactions to and from Nordea
Posted Feb 27, 2026 - 09:28 CET
This incident affected: Payment Solutions (Swish).