VAS - Coupon disturbance

Incident Report for Swedbank Pay

Resolved

This incident has been resolved.
Posted Mar 19, 2025 - 12:16 CET

Investigating

We are currently investigating this issue.
Posted Mar 19, 2025 - 10:39 CET
This incident affected: VAS (Valuecodes / Coupons).