Disturbances with clearing and settlement
Incident Report for Swedbank Pay
Resolved
This incident has been resolved. We do apologize for the inconvenience this may have caused you.
Posted Jul 25, 2022 - 15:00 CEST
Update
We are still investigating to find out the root cause to the incident
Posted Jul 25, 2022 - 11:09 CEST
Investigating
We are currently experiencing disturbances with our clearing and settlement services. Thank you for your patience.
Posted Jul 25, 2022 - 09:19 CEST
This incident affected: Acquiring of Card Transactions (Clearing & Settlement).