Issues in Merchant Portal affecting login

Incident Report for Swedbank Pay

Resolved

This incident has been resolved.
Posted Apr 09, 2026 - 16:22 CEST

Monitoring

We have identified the root cause of the issue affecting the Merchant Portal and have implemented a fix. The fix is currently being verified to ensure stability and full functionality.

We will provide an update once verification is completed.

Thank you for your patience.
Posted Apr 09, 2026 - 15:20 CEST

Investigating

We are currently experiencing issues with the Merchant Portal, including performance degradation and limited access to the portal.

The issue is being addressed to restore full functionality as soon as possible.

Thank you for your patience.
Posted Apr 09, 2026 - 11:15 CEST
This incident affected: Web Portal's (Merchant Portal).