Service Disruption
Incident Report for Swedbank Pay
Resolved
This incident has been resolved.
Posted Sep 10, 2024 - 02:43 CEST
Update
We are continuing to investigate this issue.
Posted Sep 10, 2024 - 02:28 CEST
Investigating
We are currently investigating this issue.
Posted Sep 10, 2024 - 02:14 CEST
This incident affected: Payment Solutions (Instore Card Payments, m/ecom Card Payments, Vipps).