Phone Service Disruption

Incident Report for Swedbank Pay

Resolved

This incident has been resolved.
Posted Jun 23, 2025 - 17:23 CEST

Identified

We are currently experiencing issues with our phone lines due to a disruption at our provider. As a result, it is currently not possible to reach us by phone.

In the meantime, please contact us via email:

For questions regarding card acquiring, email: support@swedbankpay.se
For questions regarding payment terminals or e-commerce, email: support.psp@swedbankpay.se
To reach our sales department, email: sales@swedbankpay.se

We apologize for the inconvenience and appreciate your understanding and patience.
Posted Jun 23, 2025 - 15:47 CEST
This incident affected: Contact Channels.