Disturbances at 3rd party

Incident Report for Swedbank Pay

Resolved

This incident has been resolved.
Posted Nov 21, 2023 - 18:16 CET

Identified

We are currently experiencing a service disruption at third party. Our external provider/supplier is investigating the issue. Thank you for your patience.
Posted Nov 21, 2023 - 17:36 CET
This incident affected: Payment Solutions (Swish).