Disturbances at 3rd party
Incident Report for swedbankpay
Resolved
This incident has been resolved.
Posted Sep 19, 2022 - 10:49 CEST
Identified
We are currently experiencing a service disruption at third party. Our external provider/supplier is investigating the issue. Thank you for your patience.
Posted Sep 19, 2022 - 09:57 CEST
This incident affected: Payments (Instore Card Payments).