Disturbances with clearing and settlement, Swedbank Pay PSP
Incident Report for Swedbank Pay
Resolved
This incident has been resolved. We do apologize for the inconvenience this may have caused you.
Posted Dec 01, 2022 - 15:01 CET
Investigating
We are currently experiencing disturbances with our clearing and settlement services. Due to these disturbances the clearing and settlement files from Swedbank Pay PSP have not been processed. Thank you for your patience.
Posted Dec 01, 2022 - 08:31 CET
This incident affected: Acquiring of Card Transactions (Clearing & Settlement).