Delayed in clearing from third party
Incident Report for Swedbank Pay
Resolved
This incident has been resolved, all files are now delivered. We do apologize for the inconvenience this may have caused you.
Posted Jun 14, 2022 - 15:34 CEST
Investigating
We have a delay due to late delivery of files from a third party. We are investigating the incident and will keep this post updated. We do apologize for the inconvenience this may have caused you.
Posted Jun 14, 2022 - 12:07 CEST
This incident affected: Acquiring of Card Transactions (Clearing & Settlement).