Swish Service Disruption

Incident Report for Swedbank Pay

Resolved

This incident has been resolved.
Posted Jun 10, 2025 - 06:44 CEST

Identified

Swish are performing a planned maintenence that may impact Swish payments.
Posted Jun 10, 2025 - 05:01 CEST
This incident affected: Payment Solutions (Swish).