Swish Service Disruption
Incident Report for Swedbank Pay
Resolved
This incident has been resolved.
Posted Nov 24, 2022 - 08:57 CET
Update
We are continuing to work on a fix for this issue.
Posted Nov 24, 2022 - 08:57 CET
Identified
We are currently experiencing a service disruption. We are working to restore the service as soon as possible. Thank you for your patience.
Posted Nov 24, 2022 - 08:14 CET
This incident affected: Payment Solutions (Swish).