3D Secure authentication degradation
Incident Report for Swedbank Pay
Resolved
This incident has been resolved.
Posted Jun 17, 2022 - 00:32 CEST
Identified
We are currently experiencing a service degradation. We are working to restore the service as soon as possible. Thank you for your patience
Posted Jun 17, 2022 - 00:18 CEST
This incident affected: Payment Solutions (m/ecom Card Payments).